読者です 読者をやめる 読者になる 読者になる

rpmforgeとかで間違えたバージョンを入れちゃった時にどうするか

CentOS 6.6にel5のパッケージ入れててハマったのでメモ

rpm -qa | grep forge で探す
rpm -e rpmforge-hogehoge で消す

rpm -ivh 正しいパッケージ で入れなおす
これて直ったかと思ったら相変わらずel5のファイルをインストールしていてエラーが出る。

clean all とかDBのrebuildしたけどうまく行かず

sudo rm -fr /var/cache/yum/*
でキャッシュを消してなおった